"Update Required" Error Message

If you are receiving an error message indicating your app is outdated, this is caused by your camera's firmware version and your app's software version being incompatible with each other.

If you see this message, force close the app on your mobile device. Check the App Store or Google Play for any available app updates. Run the update if it's available, then relaunch the app and run any available firmware updates.

If this continues, perform a hard reset of the camera and then update the firmware as prompted. This will install the proper firmware that works with the app version your device has installed.

Android Users: Another option to resolve this is to install a beta via Google Play.

If the issue still persists, please contact us.