"Update Permissions" When Attempting to Go Live

If you attempt to go live to Facebook with Mevo and see the following message, there are a few possible causes to this.

First, tap Update; since becoming a part of Vimeo, Mevo now uses the Vimeo integration in Facebook rather than the previously-used Mevo integration, which may be prompting this update. Follow the on-screen steps, then try going live again.

If you continue to see this message, it could be due to the following:

You are logged into a different Facebook account in Safari. If you are using an iOS device and see this message, navigate away from the app, launch Safari and navigate to Facebook.com. Make sure you are logged into the proper account to which you are trying to stream.

You are using an outdated version of the Mevo app. Mevo version 1.8.2 and earlier will display this error due to referencing an old Facebook API. Be sure to check the App Store or Google Play and update the app as prompted.

If you continue to see this error message, please contact us.